Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 20:00 CET
Scheduled
We will perform a planned update of the Credit Board service on 25/11-2025 starting at 20:00 CEST. During the release, the service might be unresponsive for up to 2 minutes.
Posted Nov 24, 2025 - 11:21 CET
This scheduled maintenance affected: Credit Board.